Store Locator Issues
Incident Report for Locally
Resolved
This incident has been resolved.
Posted Jun 18, 2024 - 15:47 UTC
Update
We are continuing to investigate this issue.
Posted Jun 18, 2024 - 15:46 UTC
Investigating
We have discovered the problems causing issues on Store Locators. Store Locators should be working as expected now.
Posted Jun 18, 2024 - 15:22 UTC
This incident affected: Store Locators.